193
Review on Communication Security Issues in IoT Medical Devices
10.2.2.2 Infrastructure
Infrastructure-based IoT protocols are the basic blocks of connecting devices and routing
the data packets.
1. 6LoWPAN
Expansion of 6LoWPAN is IPv6 over low power, wireless personal area networks.
In IEEE802.15.4, links of 6LoWPAN perform as an alteration layer on behalf of the
IPv6. Sensor usage and communication capability in wireless network is provided
by EEE 802.15.4 standard. 6LoWPAN protocol is capable of transferring 250 kilo
bytes and 2.4GHz is the operating frequency.
2. IPv4/IPv6
Usage of IPv6 with the existing IPv4 over transition technology hinders security
management. Weak IPv6 security strategies are an immediate consequence of the
present shortage in IPv6. To take care of this issue, the IP network threat ontology
presented to gather and analyze different network security issues on IPv4 and
IPv6 are discussed by Tseng et al. (2014).
3. RPL
Routing protocol(RPL) is used to overcome the issues of RFC5867, RFC5826,RFC5673
and RFC5548 standards. Winter and Thubert 2012 were examined RPL in low control and lossy networks(LLNS) to resolve the inefficiency routing, poor memory
usage and lack of durability in battery capacity in network node).
10.2.2.3 Identification
Identification-based IoT protocols are an interface to identify the tag/device using a reader.
1. EPC
EPC air interface protocol characterizes the physical and coherent prerequisites
for an RFID framework. This protocol is capable of to work with in the range of 860
MHz to 960 MHz ultra high frequency (UHF). In the last 10 years, EPC Generation
2 has perceived itself as the standard for UHF executions over numerous portions,
and is at the heart of more RFID usage (Anonymous 2016d).
2. uCode
ucode [UCODE] is an identifier to be stored in many types of tags. The embedding of ucode in many types of tags like RFID tags, infrared markers, optical
code, and even sound source is also identified by the Ubiquitous ID Center.
The length of ucode is 128 bits; these details of ucode are stated by Ishikawa
(2012).
10.2.2.4 Discovery
Discovery-based IoT protocols are used to search for a set of factors in devices to
communicate.
1. Physical Web
The Physical Web allows to view a set of URLS that are communicated by any
devices which is surrounded by bluetooth low energy (BLE) signal area. Bluetooth
Précédent

- 218/358

Suivant